Mail-App kann keine Mails für E-Mail-Account auf eigener Umlaut-Domain (IDN) versenden, aber empfangen

Diskutiere, Mail-App kann keine Mails für E-Mail-Account auf eigener Umlaut-Domain (IDN) versenden, aber empfangen in iPhone Allgemein forum; Der Apple-Mail-Client unter iOS hat wohl seit längerer Zeit Probleme, Mails von einem Account...
S
S.
User
  • Mail-App kann keine Mails für E-Mail-Account...
  • #1
Der Apple-Mail-Client unter iOS hat wohl seit längerer Zeit Probleme, Mails von einem Account einer Umlaut-Domain/mit einem Internationalized Domain Name (IDN) (Absender: beispiel@müller.de) zu versenden, empfangen dagegen geht problemlos. Wenn ich meinen Google-Suchen trauen kann, ging es wohl zuletzt mit iOS 13, spätestens wohl nicht mehr mit iOS 14. Inzwischen habe ich ein neues iPhone17 mit iOS 26, damit habe ich es versucht: es geht immer noch nicht. :-(

Das Problem habe ich heute in zwei längeren Telefonaten der Apple-Support-Hotline erklärt:

  • Der erste First-Level-Support-Mitarbeiter war sehr freundlich und hilfreich, hat sich das wirklich im Detail erklären und per Screen-Share zeigen lassen, das es unter iOS 26 nicht funktioniert, auf meinem (alten) MacOS mit Apple Mail mit dem selben E-Mail-Account, den identischen Einstellungen, dagegen wunderbar (das macht übrigens ziemlich deutlich, dass es nicht an meinem Domain-Provider und dessen Mail-Software - im konkreten Fall Postfix - liegt).
  • Dadurch kam ich dann zum Second-Level ("Vorgesetzten" in Apple-Support-Sprache). Auch die Support-Mitarbeiterin war sehr freundlich, hat sich das Problem im Detail erklären lassen, nach dem Domain-Provider gefragt, mich das ganze auf einem iPad gegenprüfen lassen (geht dort weil auch iOS natürlich ebenfalls nicht). Alles mit der Absicht/dem Verspechen, daraus dann ein Ticket für die Entwicklung ("Engineering" in Apple-Support-Sprache) zu machen. Am Ende hat sie dann gesehen, dass ich noch iOS 26 und nicht iOS 26.1 hatte. Ich sollte daher ein Update machen und mich melden, wenn es nach dem Update nicht funktioniert, da die Entwicklung sonst das Ticket ablehnen würde.
  • Jeder der etwas Erfahrung mit Software-Entwicklung hat, ahnt, wie es nach dem Update aussehen wird. Ich habe das Update trotzdem gemacht, verifiziert, das es immer noch nicht funktioniert und unter dem bestehenden, mir zugesendeten Fall-Link den Rückruf initiiert.
  • Entgegen der Aussage vom Second-Level vor dem Update, bin ich nicht direkt beim Second-Level gelandet sondern erst einmal wieder im First-Level. Die Informationen aus dem ersten Call waren dort entweder nicht verfügbar oder wurden erst einmal nicht verstanden. :-( Erst nach einigem hin und her mit fehlerhaften / unpassenden Aussagen aufgrund des zuerst nicht verstandenen Problems, wollte der neue First-Level mit dem Second-Level sprechen/mich an diesen weiterleiten. Das ging drei Mal hin und her, direkt zum Second-Level kam ich diesmal nicht. Laut Aussagen des First-Level wollte der Second-Level den Call von mir persönlich nicht annehmen.
  • Am Ende wollte mich der First-Level mit der generischen Aussage abspeisen, dass das ein iOS-Fehler sei und daher frühestens mit dem nächsten iOS-Update lösbar (eine Trivialität und natürlich nicht hilfreich). Meine Aussage, das ohne eine sinnvolle, qualifizierte Fehlermeldung die Entwicklung das nie fixen wird und daher der Second-Level eine Fehlermeldung anlegen muss, wurde mit der Bemerkung abgetan, das ich ja die Möglichkeit eines Feedback habe und das dort schreiben könnte. Das ist natürlich absoluter Unsinn, weil das Feedbackformular bewertet den Support-Vorgang, das führt nicht zu einer Fehlermeldung in der Entwicklung. :-(

In Summe: Der erste Teil des Supportprozesses war gut bis okay, der zweite Teil eher unterirdisch.

Das führt mich jetzt hierher, damit das Problem im iOS-Mail-Client vielleicht doch noch im Rahmen von iOS 26.x gelöst wird. Ich hoffe, die Support-Mitarbeitenden hier schaffen es, daraus eine Fehlermeldung für die Entwicklung zu machen, damit dieses seit langem existierende Problem endlich einmal gelöst wird.

PS: Aussagen wie, ich sollte doch die Domain ohne Umlaut registrieren, IDNs sind doof, etc. sind nicht hilfreich und werde ich ignorieren. Dafür gibt es offizielle Standards/RFCs, Apple sollte das heutzutage hinbekommen.


 
A
Shona

Lösungsvorschläge

Hey,

Ich empfehle dir, diese Artikel genauer unter die Lupe zu nehmen:
  • Mail-App kann keine Mails für E-Mail-Account...
  • #2
Hallo Stefan-K-DECH,

tut mir leid, dass du schlechte Ergahrung mit dem Support gemacht hast, ich hatte da bislang nie ein Problem, wenn ich mich auf ein bestehendes Ticket bezog, das schon von der „Vorgesetzten Abteilung“ bearbeitet hatte.

ich wollte aber eigentlich auf das“Feedback“-Problem eingehen. Natürlich hast du recht, dass es extrem unwahrscheinlich ist, dass dein Feedback zum Verlauf des Support Calls in der Entwicklung landet.

Tatsächlich gibt es aber unter der Adresse Product Feedback die Möglichkeit, Bugs (und Produktwünsche) an Apple zu kommunizieren.
 
  • Ersteller
  • Mail-App kann keine Mails für E-Mail-Account...
  • #3
Hallo MRGL,

danke für deinen Tipp. Werde ich probieren.

Aber nachdem ich mich durch die Meldungen/Diskussionen in der Community durchgelesen habe, ist meine Hoffnung beschränkt: :-(


Viele Leute haben das mit mehrfach verifizierten Settings probiert, die mit MacOS und/oder anderen Mail-Clients auf iOS absolut funktioniert haben, es hat sich bei ihnen also genauso wie bei mir nicht um eine simplen Konfigurationsfehler gehandelt. Trotzdem gibt es mehr als 10 iOS-Releases später immer noch keine Lösung. :-(

Das alles obwohl die zugrundeliegenden Standards/RFCs schon (für Internetzeiträume) "uralt" sind. Die letzten RFCs, die dort soweit ich das sehe etwas geändert haben (RFC6530, RFC6531, RFC6532, RFC6533), sind von 2012. Und die Standards sind nicht nur abstrakt, sie wurden umgesetzt:


Will sagen: Apple hatte mehr als genug Zeit und Möglichkeiten, zu sehen, wie man das macht. Es gibt sowohl Beispiele für Client-Software als auch genug Unterstützung bei SMTP-Servern heutzutage.

Eine Stackoverflow-Diskussion von 2023 (What is the current (2023) state of using internationalized email addresses?) sieht im Domain-Part übrigens kein Problem, nur beim Mailbox-Teil.

Und IDNs (sollten) via ACE/Punycode auch ohne SMTPUTF8 schon lange vorher funktionieren. Und nur um der Frage vorzubeugen: Ich habe meinen Benutzername für die Anmeldung am SMTP-Server sowohl in der ACE/Punycode-Variante angegeben wie auch in der IDN-Form (Beispiel von IDN-Domains):

  • IDN-Form: überall-ist.de
  • ACE-String: xn--berall-ist-8db.de

Aktuell ist die ACE-Version in meiner Konfiguration drin, es bräuchte also noch nicht einmal EAI / SMTPUTF8.

Nachdem ich das jetzt alles zusammengesucht und -geschrieben habe, werde ich den Link auf die Diskussion als Basis für das Feedback/die Fehlermeldung bei deiner Apple-Adresse nutzen. Und vielleicht hilft es ja auch anderen Leuten. :)
 
  • Ersteller
  • Mail-App kann keine Mails für E-Mail-Account...
  • #4
  • Mail-App kann keine Mails für E-Mail-Account...
  • #5
Hier gibt es keine „Support-Mitarbeiter“. Du bist in einem Userforum.

Auf die Entwicklung von iOS-Updates und die Eliminierung von Bugs haben wir keinen Einfluss.

Wenn der Support dir mitteilt, es handle sich um ein bekanntes Problem, an dem gearbeitet würde, wirst du das wohl so akzeptieren müssen.
 
  • Ersteller
  • Mail-App kann keine Mails für E-Mail-Account...
  • #6
Das weiß ich, dass das eine Community ist. Und ich weiß aber auch, dass der Support die Community liest, war heute im Call offensichtlich (und ich weiß, dass in anderen Unternehmen der Support natürlich auf die Community schaut).

Und nein, wie du oben lesen kannst, war die Aussage vom Support eben nicht, dazu gibt es ein Ticket in der Entwicklung, an dem gearbeitet wird. Sondern nur, vielleicht hast du Glück, und eventuell ist es in einem zukünftigen Release gefixed. Etwas schwache Hoffnung, bei einem offensichtlich schon sehr lange bestehenden Problem.
 
  • Mail-App kann keine Mails für E-Mail-Account...
  • #7
Hallo Stefan-K-DECH,

es ist faszinierend, wie intensivier dich mit der Materie beschäftigt hast. Umso wichtiger ist es, dein Feedback an Apple zu geben. Ich gehe absolut davon aus, dass es zumindest gelesen wird. Inwiefern daraus dann Implementierungen daraus abgeleitet werden, ist natürlich eine andere Frage.
 
Thema: Mail-App kann keine Mails für E-Mail-Account auf eigener Umlaut-Domain (IDN) versenden, aber empfangen

Similar threads: Mail-App kann keine Mails für E-Mail-Account auf eigener Umlaut-Domain (IDN) versenden, aber empfangen

App "Mail" empfängt keine Mails von anderen Accounts: Hallo, habe mir vor einigen Tagen erstmals ein I-Phone zugelegt und taste mich nach und nach an den Funktionen heran. Dabei ist mir aufgefallen...
Die Mail-App des iPhone 16 empfängt und sendet keine Mails mehr seit dem Update auf iOS 26: Die Neuinstallation von Gmail hat keine Verbesserung gebracht. Zum Glück haben wir noch einen PC mit Win 11 damit klappt noch alles. Weiß einer...
E-Mails sind weg nach dem Löschen der Mail-App: Ich habe die Mail App gelöscht und dann neu runtergeladen und dann waren alle emails weg [Betreff vom Moderator bearbeitet] 256118275
E-mails wurden von einem Ordner in der Mail App gelöscht: Hallo ich habe einen Ordner " Belege2025" erstellt und dort über Wochen Email verschoben mit Belegen Anhang. Jetzt sehe ich dass der Ordner leer...
iOS 18.4.1 Mail App vertauscht E-Mails: Ich habe ein großes Problem, seit dem Update. Meine Mails werden durcheinander gewürfelt. In der Vorschau wird mir unter dem Absender-Namen eine...
Gesendete Mails synchronisieren sich nicht mit App Mail & web.de: Hallo zusammen, ich habe seit einer Weile das Problem, dass sich meine Gesendeten Mails nicht mit den anderen Geräten synchronisieren. D. h. wenn...
Zurück
Oben